Get Flickr Photo Album to work with WordPress 2.3

I upgraded my blog to WordPress 2.3 when it released last week and had a great deal of trouble trying to get things to work out here.

This is one major release of WordPress, that really requires you to check all your plugins.

Anyway, one of my favorite plugins is Flickr Photo Album, which allows me to easily integrate Flickr with my photos’ page out here.

The current version of the plugin throws up a

Fatal error: Cannot redeclare get_users_drafts()

This has happened because WordPress 2.3 has done away with admin-db.php and now uses user.php to call the same function.

I found a solution in the Flickr Forum. Open wp-content/plugins/silaspartners/flickr/admin_options_load.php and find

require_once(dirname(__FILE__).$tmpPath.'/wp-admin/admin-db.php');

Replace with:

// changed since WP2.3
require_once(dirname(__FILE__).$tmpPath.'/wp-admin/includes/user.php');

This should fix the error and get your album working perfectly once again. Just need to wait till the author fixes this.

(Visited 302 times, 1 visits today)

2 thoughts on “Get Flickr Photo Album to work with WordPress 2.3”

  1. Hi there,
    In my opinion I think that is a problem with php installed on the server.
    Anyway I don’t like to combine flickr stuff with the blog theme.
    All the best,
    Vic

Comments are closed.